登录 用户中心() [退出] 后台管理 注册
   
您的位置: 首页 首页 >> SoftHub >> SoftHub >> 主题: xcode版本全集收藏帖子[ios,mac,苹果,iphone][最新Xcode_8.2.1]    [最新]
xcode版本全集收藏帖子[ios,mac,苹果,iphone][最新Xcode_8.2.1]
clq
浏览(0) - 2018-09-27 14:37:41 发表 编辑

关键字:

[2019-03-24 11:58:37 最后更新]
xcode版本全集收藏帖子[ios,mac,苹果,iphone][最新Xcode_8.2.1]

因为苹果的政策,xcode 对操作系统版本和 ios 都有各种限制. 为了最大限度的兼容性,有时我们不得不装上好几个版本的 xcode ...

1.
--------------------------------------------------
Xcode安装包(7.2、7.3、8.0、8.1、8.2、8.2.1)
2017年02月26日 23:41:32 HuberyYang 阅读数:1776 标签: xcode 安装包 更多

版权声明:本文为博主原创文章,转载请注明。 https://blog.csdn.net/a44496913/article/details/57603433

       在整理资料时发现电脑上收藏了常用的几个版本的Xcode安装文件,回想自己当初寻找某个版本Xcode辛苦,所以就把现有的资源拿出来,方便有需求的小伙伴使用,下面上链接:


Xcode_7.2     链接:  https://pan.baidu.com/s/1nvM59ZN    密码: fwe6

Xcode_7.3     链接:  https://pan.baidu.com/s/1qYbIurq       密码: 68d7

Xcode_8.0     链接:  https://pan.baidu.com/s/1dF1hkul       密码: vk7b

Xcode_8.1     链接:  https://pan.baidu.com/s/1i5xBp7v       密码: 27h8

Xcode_8.2     链接:  https://pan.baidu.com/s/1eRPl7d4      密码: ci4f

Xcode_8.2.1  链接:  https://pan.baidu.com/s/1cMSaku       密码: 5fr6

--------------------------------------------------
2.
让Xcode7.2支持iOS9.3设备真机调试方法--新增支持iOS10.2   
来自 http://www.cocoachina.com/bbs/read.php?tid-1686810-page-1.html


来源于 已解决 分类
让Xcode7.2支持iOS9.3设备真机调试方法--新增支持iOS10.2  
新增支持iOS10.2真机调试.压缩包下载链接:https://pan.baidu.com/s/1kURGa71
新增支持iOS10.1真机调试.压缩包下载链接:https://pan.baidu.com/s/1kU6EKE7
新增支持iOS10真机调试.压缩包下载链接:https://pan.baidu.com/s/1i48eobb 


Xcode7.2最高只支持iOS9.2设备的真机调试,一般方法是升级Xcode到7.3版本,但是7.3版本好像不是很受大家欢迎,AppStore里面也是很多差评.所以在这里为不想升级Xcode7.3的朋友提供一个方法--不用升级Xcode,让Xcode7.2支持iOS9.3设备调试.
步骤如下:
1.从网上下载Xcode7.3.dmg(下载方法)

2.安装(注意选择保留两者,不要选择替换).

3.找到应用程序,显示包中的文件.

4.进入如下目录:/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport     找到9.3文件夹

5.将找到的9.3文件夹拷贝到Xcode7.2中的对应目录中去.路径同上

6.重新打开Xcode7.2,连接上真机选择编译,第一次过程可能需要点时间,请耐心等待.
不出意外的话,可以正常编译运行了!!!

Xcode7.3有4个多G,为了节省大家时间,附上9.3文件夹的压缩包.直接拿去用吧.



clq  2018-09-27 15:43:40 发表 编辑

另外我搜索到了 9.3 (13E230).zip 的调试虚拟机文件,如下

https://pan.baidu.com/s/1bovOiOf

clq  2018-09-27 19:04:22 发表 编辑

9.3 的文件其实 9.3.2 的 ios 真机也能用,我刚复制文件里仍然提示无法使用. 其实版本数一位小数点相同就可以了的,小数点第二位对设置支持来说不是必须的. 我的 xcode 6.1 都能用.

如正面这个帖子,所说,不行的话,完全退出 xcode 后再打开项目,等待进度条读取完成再进行就可以了.

http://www.cocoachina.com/bbs/read.php?tid-1693075-page-3.html
"是不是接上手机,没等读条走完就运行了,得等到读条走完,识别了之后才运行"

另外,这种真机运行是处于调试状态的,需要先制作 dev 的 pf 文件. 否则会有出错提示的.


总数:2 页次:1/1 首页 尾页  
总数:2 页次:1/1 首页 尾页  


该采集也在以下书单中
xcode 更多



发表评论:
文本/html模式切换 插入图片 文本/html模式切换


附件:



NEWBT官方QQ群1: 276678893
可求档连环画,漫画;询问文本处理大师等软件使用技巧;求档softhub软件下载及使用技巧.
但不可"开车",严禁国家敏感话题,不可求档涉及版权的文档软件.
验证问题说明申请入群原因即可.

Copyright © 2005-2017 clq, All Rights Reserved
CLQ工作室 版权所有